Pontiac GTA Enhancement information and discussions with Technical DIY and performance tuning information for the hardcore Pontiac GTA Owners and Enthusiasts.
Forum | Register Now | Members | Search | How Do I... | Calendar

Go Back   The GTA Source Page Message Forums > GTA SPECIFIC > GTA TECH

GTA TECH Want to discuss technical topics about your GTA.... engine tuning, mechanical upgrades, problem areas, etc.? Then post it HERE!

Reply
 
Thread Tools Display Modes
Old 06-08-2015   #1
Winchester1094
Registered User
 
Winchester1094's Avatar
 
Join Date: Jun 2015
Location: Eastern shore MD
Posts: 11


87 GTA idle hunt code 44

Hi I recently bought an 87 gta with the l98 that had been sitting for a few years. Dropped the tank put in a new tank/pump/sender/filter. Car started up ran like shit rolled some coal for a bit then cleaned up. Took it down the road and noticed the ses came on then a slight stutter at cruising speeds under light throttle. Goes away under heavy throttle and idle. Proceeded to do a tune up. Plugs wires cap rotor. Started the car back up and it runs fine cold and then about 5 mins in it has a bad idle hunt. 400-700 rpm. Drives fine. Still has the stutter though so I check timing. 2d retarded. Adjust to 6 advanced with dizzy advance unplugged. Check fuel pressure at idle with reg vac line off. 50 psi. Replaced all vac lines. Same problem. Ses always comes on rig before it starts stuttering with code 44 (lean exhaust) my thoughts are bad O2 or bad/stuck open egr. Any experience with these symptoms? Also for the first about 30 seconds of a cold start the iac seems to be noisy. Lot of hissing in the front of the throttle body then it goes away.
Winchester1094 is offline   Reply With Quote
Old 06-08-2015   #2
89-5.7GTA
Tony
 
Join Date: Jul 2009
Location: Rocky River Ohio
Posts: 304



GTA Year: 1989
GTA Engine: 350 TPI Automatic
Re: 87 GTA idle hunt code 44

Be patient, this site has members that can point you in the right direction but it may take some time for them to come around. Are the injectors stock originals? I'd explore that also.
__________________
L98
700R4
3.27
89-5.7GTA is offline   Reply With Quote
Old 06-08-2015   #3
Winchester1094
Registered User
 
Winchester1094's Avatar
 
Join Date: Jun 2015
Location: Eastern shore MD
Posts: 11


Re: 87 GTA idle hunt code 44

Quote:
Originally Posted by 89-5.7GTA View Post
Be patient, this site has members that can point you in the right direction but it may take some time for them to come around. Are the injectors stock originals? I'd explore that also.
As far as I can tell yes. None of them feel "duddy" though at idle anyways. All have a nice solid tick to them
Winchester1094 is offline   Reply With Quote
Old 06-08-2015   #4
MunsonGTA
Bad luck or no luck
 
Join Date: Jun 2004
Location: Ravenna, OH
Posts: 1,948



GTA Year: 1987
GTA Engine: Custom
Re: 87 GTA idle hunt code 44

I know you replaced the vac lines, I would double check all of them. It wouldn't hurt to replace the o2 sensor. If the IAC is acting up, pull it out and clean it.
__________________
87 GTA: Forged 408 LSX short block, TEA stage 2 cnc ported 243 heads, BTR Stage 3 stroker cam, Fast 102 intake, NW 102 TB, Longtube headers, custom 411 ECM, custom harness, custom tuned, Performabuilt stage 2 4l60E with PTC 2800 stall, 9 bolt rear with 3.70 gears and TAP girdle.

11.16 at 123 mph.
MunsonGTA is offline   Reply With Quote
Old 06-08-2015   #5
Winchester1094
Registered User
 
Winchester1094's Avatar
 
Join Date: Jun 2015
Location: Eastern shore MD
Posts: 11


Re: 87 GTA idle hunt code 44

Quote:
Originally Posted by MunsonGTA View Post
I know you replaced the vac lines, I would double check all of them. It wouldn't hurt to replace the o2 sensor. If the IAC is acting up, pull it out and clean it.
I replaced all of the rubber lines but I am going to get some carb cleaner and do some spray hunting. Don't here any hissing or anything. I had a scan tool on it but never checked the O2 reading.
Winchester1094 is offline   Reply With Quote
Old 06-09-2015   #6
DynoDave
Registered User
 
DynoDave's Avatar
 
Join Date: Mar 2015
Posts: 250


Re: 87 GTA idle hunt code 44

Don't forget to try disconnecting the brake booster. It can leak too.
DynoDave is offline   Reply With Quote
Old 06-09-2015   #7
Winchester1094
Registered User
 
Winchester1094's Avatar
 
Join Date: Jun 2015
Location: Eastern shore MD
Posts: 11


Re: 87 GTA idle hunt code 44

Quote:
Originally Posted by DynoDave View Post
Don't forget to try disconnecting the brake booster. It can leak too.
True. The brakes did seem to feel a little funny as well. Another thing I've noticed is that the rear seems to have some sway to it. I put new shocks and sway bar links on it but it still feels like a minivan lol
Winchester1094 is offline   Reply With Quote
Old 06-10-2015   #8
ws6 gta
my slow junk
 
Join Date: May 2015
Location: york pa
Posts: 29



GTA Year: 1988
GTA Engine: 350 TPI Automatic
Re: 87 GTA idle hunt code 44

I'd remove the throttle and clean the blade. Check you IAC out replace it. Injection cleaner as well.
ws6 gta is offline   Reply With Quote
Old 06-10-2015   #9
Winchester1094
Registered User
 
Winchester1094's Avatar
 
Join Date: Jun 2015
Location: Eastern shore MD
Posts: 11


Re: 87 GTA idle hunt code 44

Have been running seafoam through it
Winchester1094 is offline   Reply With Quote
Old 07-13-2015   #10
Winchester1094
Registered User
 
Winchester1094's Avatar
 
Join Date: Jun 2015
Location: Eastern shore MD
Posts: 11


Re: 87 GTA idle hunt code 44

So I replaced the o2 with a bosch. Was an original ac delco in it and all of my symptoms have gone away. Now onto the smaller items. My dash is fully lighting except for the section with op, coolant temo, and voltage (digital) is this just a simple bulb issue or are something more serious? I've never had a digital cluster out to see how they're assembeled or how they work for that matter.
Winchester1094 is offline   Reply With Quote
Old 07-20-2015   #11
merc3065
Registered User
 
merc3065's Avatar
 
Join Date: Aug 2006
Posts: 2,057


Re: 87 GTA idle hunt code 44

"Simple" bulb issue. You need to remove the digital cluster to get at the bulbs.

To do that, the dash pad has to come off and you would do well to lower the steering wheel as well about 1".

Then getting the cluster out of the dash frame can be tricky as well as getting it to sit back in properly. If the clips for the connectors aren't brittle it should come out and in without much issue.
__________________
merc3065 is offline   Reply With Quote
Old 07-26-2015   #12
Kevs87ta
Registered User
 
Kevs87ta's Avatar
 
Join Date: Aug 2013
Posts: 124



GTA Year: 1990
GTA Engine: 350 TPI Automatic
Re: 87 GTA idle hunt code 44

I noticed you had 50 psi...that seems pretty high for stock L98. Normal fuel pressure should be 42psi. Does the car have an adjustable fuel pressure regulator? If it does you could bump it down and see if it makes a difference...
Just my 2 cents
__________________
1990 Trans Am GTA
1982 Pontiac Firebird
1976 Trans Am
1995 LT1 Camaro
Kevs87ta is offline   Reply With Quote
Old 07-31-2015   #13
Winchester1094
Registered User
 
Winchester1094's Avatar
 
Join Date: Jun 2015
Location: Eastern shore MD
Posts: 11


Re: 87 GTA idle hunt code 44

Quote:
Originally Posted by Kevs87ta View Post
I noticed you had 50 psi...that seems pretty high for stock L98. Normal fuel pressure should be 42psi. Does the car have an adjustable fuel pressure regulator? If it does you could bump it down and see if it makes a difference...
Just my 2 cents
50 psi was with the regulator unplugged (vacuum non adjustable) it ran fine for awhile. Put about 500 miles on the car after instilling the new o2. Getting good fuel mileage etc. Just started a new problem. When the engine is cold it cranks for about 15 seconds and slowy sputters to life. You have to listen for it or you'll just keep cranking. Starter was put on as soon as I got the car as well as new battery. It cranks over a hellin just doesn't fire off as soon as you touch the key like it used to. I've heard op switch can stop the pump from running while cranking. Had someone crank the car while I had my ear against the fill tube. Pump was running. My guess is 9th injector issue or distributor pick up or ICM but I don't really want to throw parts at it. I am going to check fuel pressure while cranking and running and check for blead down as well as check injector pulse with a noid light. It's just difficult to diag because as soon as it fires once it fires almost like normal after that. Also I have had it stall after starting since this started happening. Wot is normal so I rulled out fuel filter which also has 500 miles on it with a brand new tank sender and Bosch "OE upgrade" pump.I should also note that it lets off a cloud of smoke when started cold as well.
__________________
87 GTA
L98
700R4
3.27
All Stock

Last edited by Winchester1094; 07-31-2015 at 07:47 AM.
Winchester1094 is offline   Reply With Quote
Old 07-31-2015   #14
Winchester1094
Registered User
 
Winchester1094's Avatar
 
Join Date: Jun 2015
Location: Eastern shore MD
Posts: 11


Re: 87 GTA idle hunt code 44

Key on 42 psi. Same cranking. 37 psi idling. Put a test light on #1 injector. Both sides hot no pulsing or maybe to fast for my bulb?
__________________
87 GTA
L98
700R4
3.27
All Stock
Winchester1094 is offline   Reply With Quote
Old 08-03-2015   #15
merc3065
Registered User
 
merc3065's Avatar
 
Join Date: Aug 2006
Posts: 2,057


Re: 87 GTA idle hunt code 44

Check your plugs. The L98s had crappy valve seals and it allows oil to leak into the cylinders and foul or shroud the plug. You may have ash build up on the plugs. Also the 87-88 ecm startup allows for 3 complete revolutions to prime the engine before starting. The 89 changed out the cold start injector and i found that it started easier. I also programmed it to start as soon as you turned the key.

Check for bleed down after powering off. It should hold 42psi for at least 5-10 mins. If you have bleed down it can be leaky injector or even a leaky gas cap.
__________________
merc3065 is offline   Reply With Quote
Old 08-11-2015   #16
Winchester1094
Registered User
 
Winchester1094's Avatar
 
Join Date: Jun 2015
Location: Eastern shore MD
Posts: 11


Re: 87 GTA idle hunt code 44

I am now getting a code 34 (MAF low) code upon cold starts. Intermittent hard starts. Any ideas
__________________
87 GTA
L98
700R4
3.27
All Stock
Winchester1094 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GTA out yesterday YumikoGTA GENERAL DISCUSSION (NON-GTA) 8 10-25-2011 01:20 AM
Why I have a GTA and belong to this site. GTA50 GENERAL DISCUSSION (NON-GTA) 22 05-02-2010 07:36 PM
Personal GTA anniversary next month Brett89GTA GENERAL DISCUSSION (NON-GTA) 7 08-18-2009 07:14 AM
91 & 92 GTA Parts Needed - Some Camaro Parts Too Andy 91GTA GTA PARTS WANTED 2 04-19-2007 11:15 PM
Happy Birthday to my GTA TripleTransAm GTA MISC 4 06-11-2006 09:29 PM


All times are GMT -5. The time now is 10:50 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.