Pontiac GTA Enhancement information and discussions with Technical DIY and performance tuning information for the hardcore Pontiac GTA Owners and Enthusiasts.
Forum | Register Now | Members | Search | How Do I... | Calendar

Go Back   The GTA Source Page Message Forums > GTA SPECIFIC > GTA TECH

GTA TECH Want to discuss technical topics about your GTA.... engine tuning, mechanical upgrades, problem areas, etc.? Then post it HERE!

Reply
 
Thread Tools Display Modes
Old 08-13-2011   #1
88 Black GTA
GTA fanatic
 
Join Date: Apr 2007
Location: Owatonna, Mn
Posts: 153


problem with my digital dash.

I took my Son for a ride in the GTA the other day and the speedometer and information center no longer work. The speedometer reads in kilometers per hour now and stays at 0 regardless of how fast I am going. The gauges work okay but the odometer is blank. I checked the fuses and they look good. Is it time to get my dash rebuilt? Does anyone have any idea what might the wrong.
__________________
1988 GTA 5.7/700R4 Black/Black leather

Firebird owners of Minnesota - Facebook.
88 Black GTA is offline   Reply With Quote
Old 08-13-2011   #2
rhomanski
The Born Loser
 
rhomanski's Avatar
 
Join Date: Nov 2010
Location: Southside Batesville Arkansas
Posts: 313



GTA Year: 1988
GTA Engine: 350 TPI Automatic
Re: problem with my digital dash.

If it's been sitting for a while, something probably corroded. try switching from standard to km a few times and if that doesn't help take it out and unplug and replug everything. Spray the switch with Caig Deoxit D5 from an electronics place and it will clean the corrosion. You can also clean the plugs with it too.

Regards,

Ron.
__________________
A Country Is Built On Cooperation
An Empire Is Built On Slaves
rhomanski is offline   Reply With Quote
Old 08-13-2011   #3
88 Black GTA
GTA fanatic
 
Join Date: Apr 2007
Location: Owatonna, Mn
Posts: 153


Re: problem with my digital dash.

Thanks, I will give that a try. It sits more than I like, and it's been at least a month since I drove it last. When it first happened it still read 0 in miles per hour, when I restarted the car is registered in kilometers per hour and won't switch back.
__________________
1988 GTA 5.7/700R4 Black/Black leather

Firebird owners of Minnesota - Facebook.
88 Black GTA is offline   Reply With Quote
Old 08-14-2011   #4
merc3065
Registered User
 
merc3065's Avatar
 
Join Date: Aug 2006
Posts: 1,982


Re: problem with my digital dash.

VSS module on the ECM may have failed.
It's a yellow plastic thingy that is connected to the outside of the ECM case.

It's more likely given up the ghost. Otherwise the VSS sensor on the transmission is no longer functioning.

Basically that little module will cause problems for torque converter lockup, 4th gear request etc.

Check the button to see if it works, but more likely it's the VSS module on the ECM.
__________________
merc3065 is offline   Reply With Quote
Old 09-01-2011   #5
GhostGTA
GhostGTA
 
Join Date: Jul 2011
Location: Colorado
Posts: 46



GTA Year: 1988
GTA Engine: 350 TPI Automatic
Re: problem with my digital dash.

Both Merc3065 and rhomanski are right in their diagnosis... I took their advice and pulled my VSS buffer cleaned it up with electronic connector cleaner from NAPA and like magic! I had my dash working again! The car had been sitting since 2003 when I picked it up a month ago. Thanks guys.
__________________
Buying motorcycle trailer from friend $400
Trading motorcycle trailer for 81 Chevy Pkp $0
Trading pickup for 88 GTA PRICELESS!!!
GhostGTA is offline   Reply With Quote
Old 10-08-2011   #6
1986WS6
Registered User
 
Join Date: Sep 2010
Location: Lancaster, California
Posts: 34


Re: problem with my digital dash.

My '86 t/a has the digital dash factory but the odometer has always light up half the numbers I tried to remove the odometer and then connected it it back and light up but then the numbers disappeared I recently swapped a '89 has a new '89 vss buffer I haven't tried starting it cause im still working on her any suggestions or anybody who repairs digital dash
1986WS6 is offline   Reply With Quote
Old 10-21-2011   #7
88 Black GTA
GTA fanatic
 
Join Date: Apr 2007
Location: Owatonna, Mn
Posts: 153


Re: problem with my digital dash.

I still haven't had time to look too far into it but I did drive it the other day and just used my GPS as a speeding. The cruise still works and the lock up on the tranny works fine so I think the VSS is ok. I work road construction and right now time is hard to come by but when I can find some I am going to pull the gauge panel and check and clean the connectors and see if that does the trick.
__________________
1988 GTA 5.7/700R4 Black/Black leather

Firebird owners of Minnesota - Facebook.
88 Black GTA is offline   Reply With Quote
Old 10-23-2011   #8
skibum2100
Registered User
 
Join Date: Mar 2002
Location: Boulder Colorado
Posts: 20



GTA Year: 1988
GTA Engine: Custom
Re: problem with my digital dash.

Make sure a penny didn't fall into the cigarette lighter socket.

I use my ashtray as a change holder and one day a penny sloshed out, fell into the lighter socket and blew the courtesy fuse.

Hope this helps.
skibum2100 is offline   Reply With Quote
Old 10-24-2011   #9
88 Black GTA
GTA fanatic
 
Join Date: Apr 2007
Location: Owatonna, Mn
Posts: 153


Re: problem with my digital dash.

Victory is mine. Turned out to be a bad light socket in the drivers footwell. I took the bulb out and replaces the courtesy fuse and what do you know, a fully functional dash.
__________________
1988 GTA 5.7/700R4 Black/Black leather

Firebird owners of Minnesota - Facebook.
88 Black GTA is offline   Reply With Quote
Old 10-26-2011   #10
geddylee
Registered User
 
Join Date: Oct 2011
Posts: 34


Re: problem with my digital dash.

Glad to hear you got it worked out. Thats 1 thing that worried me, if the dash starts to fail.
geddylee is offline   Reply With Quote
Old 11-18-2011   #11
geddylee
Registered User
 
Join Date: Oct 2011
Posts: 34


Re: problem with my digital dash.

I seem to be having the same problem. My dash was just taken out by a local Pontiac dealer to replace a few bulbs, mainly the one that illuminates he odometer and it was fine till I got home and popped the trunk. Now the dome light is out and the power locks do not work and speedometer stays at 0. The mirrors no longer work and the odometer is completely out. Excuse my stupidity lol, but what is VSS module and where is it located? I
geddylee is offline   Reply With Quote
Old 11-19-2011   #12
rhomanski
The Born Loser
 
rhomanski's Avatar
 
Join Date: Nov 2010
Location: Southside Batesville Arkansas
Posts: 313



GTA Year: 1988
GTA Engine: 350 TPI Automatic
Re: problem with my digital dash.

Sounds like you blew the courtesy fuse. It's a 20 amp fuse located in the fuse panel. It powers the hatch release switch. Perhaps there was too small of a fuse in it, or perhaps the hatch release has a short in it somewhere. Try another fuse of the proper size. If it blows again, then you can pull the dash and hope it's just a problem they induced or start troubleshooting. If the coil of the solenoid is partially shorted it would still work but would pull extra current. Also a partial short of the wire to the solenoid would cause the same thing. If your switch broke it could keep current flowing to the solenoid and it would stay retracted until it burnt out. Although that would probably keep the motor from retracting unless you kept it open long enough the solenoid burned out and retracted.

The VSS module is located behind the dash but that is not your problem. I had a short in my dome light that caused the same thing you have. Fix the short and replace the fuse and you should be all right.

Regards,

Ron.
__________________
A Country Is Built On Cooperation
An Empire Is Built On Slaves
rhomanski is offline   Reply With Quote
Old 11-19-2011   #13
geddylee
Registered User
 
Join Date: Oct 2011
Posts: 34


Re: problem with my digital dash.

I will do. Been working a ton of ot thats why its at the dealer. Since I paid 440.00 to fix the original bulb I am going to take it back if the courtesy fuse does now fix this. Seems like alot of things dont work after the dash quit. locks, mirrors,dome lite,trunk lite but I will try that after work today. Thanks alot Ron.
geddylee is offline   Reply With Quote
Old 11-19-2011   #14
73_widetrack
Registered User
 
Join Date: Nov 2011
Location: Bayou La Batre, AL
Posts: 77


Talking Re: problem with my digital dash.

funny because I used to have a 86 Buick regal that had a digital dash. Interesting thing is some of those componients were relately robust compaired to the lighter smaller pieces used in today's modern LED/elecronic setups. Usally as mentioned it is one piece that is the stand alone problem. Since cars aren't requiired to have redundant systems for back up it will just crap the bed with little or no warning. Corrosion is a nasty thing, but if you have kept the car in a semi controlled environment it shouldn't have any issues unless there has been faultly voltage or spikes in voltage which could be caused by tin whiskers and those are killers to boards and componients.
73_widetrack is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
digital dash problem SE1979TA GTA TECH 12 07-17-2008 11:17 AM
Digital Dash Problem Francis GTA TECH 3 01-24-2006 03:09 AM
Oil Pressure gage on digital dash problem 88blackbeauty GTA TECH 2 04-01-2003 10:16 PM
digital dash problem carver GTA TECH 4 01-27-2003 11:22 PM
Digital Dash Problem Mike Valbuena GTA NON-TECH 1 03-15-2002 01:52 PM


All times are GMT -5. The time now is 10:27 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.