Pontiac GTA Enhancement information and discussions with Technical DIY and performance tuning information for the hardcore Pontiac GTA Owners and Enthusiasts.
Forum | Register Now | Members | Search | How Do I... | Calendar

Go Back   The GTA Source Page Message Forums > GTA SPECIFIC > GTA TECH

GTA TECH Want to discuss technical topics about your GTA.... engine tuning, mechanical upgrades, problem areas, etc.? Then post it HERE!

Reply
 
Thread Tools Display Modes
Old 03-04-2010   #1
ars2pd
Registered User
 
Join Date: Mar 2010
Posts: 25


Problem with my GTA (wont stay running) fuel issue?

Alright guys, Im new, but got a question about my car. I have a White 1988 GTA, 350 TPI, etc. All stock. Mileage 48,000ish.

I have noticed sometimes the check engine light comes on, but then goes off within an hour or so. Did a basic check, and everything seems fine. It idles great and shifts good, so I just figured its nothing.

Anyways, I was driving it today, went to walmart and the post office without any problems. Then, this evening, I went to start it, it starts revs a bit then dies. I sit there thinking maybe I just need to give it some gas to keep the engine primed, so I started it again, held the gas to let the RPM sit a little over 2k, then when I let off the gas it dies again. This continued 4 or 5 tries for about 10 minutes.

Im sure its something basic, and it sounds like a fuel pump or injection problem maybe? Anyways, consulting the experts, dont want to get robbed taking it in. If anyone has some troubleshooting suggestions please let me know. Thanks
ars2pd is offline   Reply With Quote
Old 03-04-2010   #2
Y84
Administrator
 
Join Date: Feb 2009
Posts: 79



GTA Year: 1988
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

If the service engine soon light comes on, even if it goes off, that means the ECM detected a fault and a trouble code is stored. Even though the system is primitive compared to today, it's probably in your best interest to have the trouble codes pulled from the ECM as that's part of it's diagnostic capabilities.
Y84 is offline   Reply With Quote
Old 03-04-2010   #3
ars2pd
Registered User
 
Join Date: Mar 2010
Posts: 25


Re: Problem with my GTA (wont stay running) fuel issue?

Well, I understand that, but I am also a college student without a lot of disposable income.

With that said, is there anywhere that will check out my codes for free / very small fee?

Also, is there anything I can try myself (without ruining anything) / small replacements to see if anything can fix?

History about the car: I bought the car this past summer with 32,150 miles. It was owned by an original owner who kept it garage stored for years. He sold it to me for $5k, and asked that I take care of it and treat it immaculately as he has (which I have). It sat for years, and still had the original tires on it. That being said with it sitting for so long, any other suggestions? It has had mobile 1 oil changes its whole life as well.
ars2pd is offline   Reply With Quote
Old 03-04-2010   #4
BigBadGTA
Vegas Cruiser
 
BigBadGTA's Avatar
 
Join Date: Jan 2009
Location: Las Vegas, NV
Posts: 644



GTA Year: 1988
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

You can actually pull the trouble codes off yourself with a paperclip. I do not remember off the top of my head but you stick both ends of the clip in different ports in the computer plug it under the drivers dash and the SES light will blink the code to you. I would do some digging for you, but I have to get up early tomorrow. I would try thirdgen.org, or I think I remember seeing an article about it on high performance pontiac's site. Good luck!
__________________


1988 GTA, 5.7L 350TPI

Visit My Cardomain! LINK
BigBadGTA is offline   Reply With Quote
Old 03-04-2010   #5
FearThisGTA
"The only thing to fear is.............fear itself"
 
FearThisGTA's Avatar
 
Join Date: Jun 2003
Location: In front of you....
Posts: 4,742



GTA Year: 1991
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

You can find that info on TGO, or you can get a Haynes manual for around 15-20 bucks(the book has some good pm info, including all of the trouble codes). Have you been able to get it started again?
__________________


Cliff Jones
1991 GTA Trans Am
w/305,231 miles
on the original motor!!!!
Time of Death on motor, 4:07pm on 05/29/2010.
Hp:211.2@4200rpms/Tq.328.5@2700rpms
Best et: 13.959@97.05mph
Best mph: 98.3
Best 60' : 1.875 on BFG Comp TA's w/ 32 lbs of air in them
FearThisGTA is offline   Reply With Quote
Old 03-04-2010   #6
87bucketgta
BACKDOOR STRANGER
 
87bucketgta's Avatar
 
Join Date: Jul 2007
Location: KANNAPOLIS
Posts: 1,072


Re: Problem with my GTA (wont stay running) fuel issue?

Most autozones and soforth will check them for free problem is alot of them around dont have the right plug for our odb1 u just have to check with them
87bucketgta is offline   Reply With Quote
Old 03-04-2010   #7
budfreak1
stang stumper
 
budfreak1's Avatar
 
Join Date: May 2005
Location: Toronto, Oh.
Posts: 698



GTA Year: 1991
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

As Fear said, buy a haynes manual. It's worth the 20 bucks and will tell you how to check the codes and gives you a list of them all. It will also come in handy in the future considering you'll probably be doing alot of your own work.
__________________

My Cardomain
1991 GTA L98 SuperRam- 13.5@98.7 MPH
1987 GTA L98: Flame Red(R.I.P.)
Road Demon:1992 Subaru SVX- Worlds fastest street N/A auto SVX record holder
1997 Silverado 350: Daily ride
budfreak1 is offline   Reply With Quote
Old 03-04-2010   #8
87bucketgta
BACKDOOR STRANGER
 
87bucketgta's Avatar
 
Join Date: Jul 2007
Location: KANNAPOLIS
Posts: 1,072


Re: Problem with my GTA (wont stay running) fuel issue?

also google gm odb1 codes, several pages listed out there with the stuff
87bucketgta is offline   Reply With Quote
Old 03-04-2010   #9
ars2pd
Registered User
 
Join Date: Mar 2010
Posts: 25


Re: Problem with my GTA (wont stay running) fuel issue?

I have a haynes manual, but its at home and I am at college.

I have called autozone, and they said they cant get the error codes off, they can only check 96+.

However, they thought it was a fuel filter issue, or just a plug of gunk somewhere. Possibly bad gas as well since I am on the low side of the tank with about 1/4 of a tank (No, I am not out of gas, remember when I put on the throttle the engine runs fine).

Im going to go check it over now and see whats up. I dont want to tow it, and I dont have a truck either. So, its kind of stuck where it is until I can figure it out.

Can anyone find a link on how to get the code to show with a paperclip?

Thanks guys.
ars2pd is offline   Reply With Quote
Old 03-04-2010   #10
budfreak1
stang stumper
 
budfreak1's Avatar
 
Join Date: May 2005
Location: Toronto, Oh.
Posts: 698



GTA Year: 1991
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

I can't find a link for the how to on it, but if any of you out there are near Ohio and want your car monitored or codes read, I have a scanner that can do EVERYTHING.
__________________

My Cardomain
1991 GTA L98 SuperRam- 13.5@98.7 MPH
1987 GTA L98: Flame Red(R.I.P.)
Road Demon:1992 Subaru SVX- Worlds fastest street N/A auto SVX record holder
1997 Silverado 350: Daily ride
budfreak1 is offline   Reply With Quote
Old 03-04-2010   #11
ars2pd
Registered User
 
Join Date: Mar 2010
Posts: 25


Re: Problem with my GTA (wont stay running) fuel issue?

Alright, this is going to sound retarded, but can anyone show me a pic / location of the fuel filter location?
ars2pd is offline   Reply With Quote
Old 03-04-2010   #12
budfreak1
stang stumper
 
budfreak1's Avatar
 
Join Date: May 2005
Location: Toronto, Oh.
Posts: 698



GTA Year: 1991
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

Quote:
Originally Posted by ars2pd View Post
Alright, this is going to sound retarded, but can anyone show me a pic / location of the fuel filter location?
It's under the car on the drivers side as I recall. It looks like a metal canister with a fuel line coming out of each end.
__________________

My Cardomain
1991 GTA L98 SuperRam- 13.5@98.7 MPH
1987 GTA L98: Flame Red(R.I.P.)
Road Demon:1992 Subaru SVX- Worlds fastest street N/A auto SVX record holder
1997 Silverado 350: Daily ride
budfreak1 is offline   Reply With Quote
Old 03-04-2010   #13
ars2pd
Registered User
 
Join Date: Mar 2010
Posts: 25


Re: Problem with my GTA (wont stay running) fuel issue?

Just called the dealership, they said it would be $75 to run a diagnostic :/

Called a couple of my local auto repair stores, someone said it could be the idle air speed motor? I guess there is a piece by the plunger? that can mess up or get dirty? Anyone know about this or can take a pic and explain what to look for there?

I also noticed something was leaking out of my engine bay. Let me see if I can upload an image of the spot.
ars2pd is offline   Reply With Quote
Old 03-04-2010   #14
budfreak1
stang stumper
 
budfreak1's Avatar
 
Join Date: May 2005
Location: Toronto, Oh.
Posts: 698



GTA Year: 1991
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

Quote:
Originally Posted by ars2pd View Post
Just called the dealership, they said it would be $75 to run a diagnostic :/

Called a couple of my local auto repair stores, someone said it could be the idle air speed motor? I guess there is a piece by the plunger? that can mess up or get dirty? Anyone know about this or can take a pic and explain what to look for there?

I also noticed something was leaking out of my engine bay. Let me see if I can upload an image of the spot.
Take 20 dollars and buy a haynes manual. It will tell you how to read codes and what they mean and probably save you a ton of money in the long run by helping you fix stuff yourself.
__________________

My Cardomain
1991 GTA L98 SuperRam- 13.5@98.7 MPH
1987 GTA L98: Flame Red(R.I.P.)
Road Demon:1992 Subaru SVX- Worlds fastest street N/A auto SVX record holder
1997 Silverado 350: Daily ride
budfreak1 is offline   Reply With Quote
Old 03-04-2010   #15
ars2pd
Registered User
 
Join Date: Mar 2010
Posts: 25


Re: Problem with my GTA (wont stay running) fuel issue?

This is what I found leaking in the engine bay.



It leaks pretty heavily when the car has ran, and I also saw some foaming? You can see the liquid at the bottom portion of that specific part.

Also, just so you guys can see it, I put louvers on my car this past summer. Here is a pic of it while I was out there:

ars2pd is offline   Reply With Quote
Old 03-04-2010   #16
budfreak1
stang stumper
 
budfreak1's Avatar
 
Join Date: May 2005
Location: Toronto, Oh.
Posts: 698



GTA Year: 1991
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

That is the heater control valve and controls water flow to your heater core. Go to autozone and get a replacement.
__________________

My Cardomain
1991 GTA L98 SuperRam- 13.5@98.7 MPH
1987 GTA L98: Flame Red(R.I.P.)
Road Demon:1992 Subaru SVX- Worlds fastest street N/A auto SVX record holder
1997 Silverado 350: Daily ride
budfreak1 is offline   Reply With Quote
Old 03-04-2010   #17
ars2pd
Registered User
 
Join Date: Mar 2010
Posts: 25


Re: Problem with my GTA (wont stay running) fuel issue?

Quote:
Originally Posted by budfreak1 View Post
That is the heater control valve and controls water flow to your heater core. Go to autozone and get a replacement.
The piece with the 3 lines going into it, correct? Would this create the problem I am experiencing you think?
ars2pd is offline   Reply With Quote
Old 03-04-2010   #18
budfreak1
stang stumper
 
budfreak1's Avatar
 
Join Date: May 2005
Location: Toronto, Oh.
Posts: 698



GTA Year: 1991
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

Quote:
Originally Posted by ars2pd View Post
The piece with the 3 lines going into it, correct? Would this create the problem I am experiencing you think?
Correct. No it will not cause your problem but it will start overheating once it loses so much coolant.
I'd say either your idle air control is dirty/broken or maybe the TPS or MAF is having issues. Does it run good when you are holding the pedal down or does it sputter or anything? I'd figure if it was a fuel issue, it wouldn't want to run especially with the pedal pressed when it demands more fuel.
__________________

My Cardomain
1991 GTA L98 SuperRam- 13.5@98.7 MPH
1987 GTA L98: Flame Red(R.I.P.)
Road Demon:1992 Subaru SVX- Worlds fastest street N/A auto SVX record holder
1997 Silverado 350: Daily ride
budfreak1 is offline   Reply With Quote
Old 03-04-2010   #19
ars2pd
Registered User
 
Join Date: Mar 2010
Posts: 25


Re: Problem with my GTA (wont stay running) fuel issue?

Quote:
Originally Posted by budfreak1 View Post
Correct. No it will not cause your problem but it will start overheating once it loses so much coolant.
I'd say either your idle air control is dirty/broken or maybe the TPS or MAF is having issues. Does it run good when you are holding the pedal down or does it sputter or anything? I'd figure if it was a fuel issue, it wouldn't want to run especially with the pedal pressed when it demands more fuel.
It runs fine when holding the pedal down. No sputtering or anything. I have had the occasional smoke come out the back, but that was mostly due to the valve seals from what I have been told for it sitting so long. Otherwise, the car has been trouble free.

Just called autozone, and looks like they dont carry the part Any ideas of where to pick one up from without getting raped by the dealership?

Also, any noob instructions on checking the idle air control, TPS, or MAF?
ars2pd is offline   Reply With Quote
Old 03-04-2010   #20
budfreak1
stang stumper
 
budfreak1's Avatar
 
Join Date: May 2005
Location: Toronto, Oh.
Posts: 698



GTA Year: 1991
GTA Engine: 350 TPI Automatic
Re: Problem with my GTA (wont stay running) fuel issue?

Quote:
Originally Posted by ars2pd View Post
It runs fine when holding the pedal down. No sputtering or anything. I have had the occasional smoke come out the back, but that was mostly due to the valve seals from what I have been told for it sitting so long. Otherwise, the car has been trouble free.

Just called autozone, and looks like they dont carry the part Any ideas of where to pick one up from without getting raped by the dealership?

Also, any noob instructions on checking the idle air control, TPS, or MAF?
Do a search on either here or thirdgen.org and you should find directions on testing them all.
Try advance auto parts or napa, I know they are available from somewhere because I've had to replace one before.
__________________

My Cardomain
1991 GTA L98 SuperRam- 13.5@98.7 MPH
1987 GTA L98: Flame Red(R.I.P.)
Road Demon:1992 Subaru SVX- Worlds fastest street N/A auto SVX record holder
1997 Silverado 350: Daily ride
budfreak1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Repro GTA style wheel casting problem... mikedog GENERAL DISCUSSION (NON-GTA) 0 05-19-2008 10:03 PM
87 gta 305 tpi no start 87 TA GTA TECH 8 01-27-2006 05:13 PM
Overheating Problem - 88 GTA gzipin GTA TECH 5 06-09-2003 09:21 PM
GTA TPI fuel tank/pump assembly GTA91 GTA PARTS FOR SALE 0 10-02-2002 02:46 AM
GTA & Salvage Yard gtayumiko GTA NON-TECH 8 03-13-2002 12:22 AM


All times are GMT -5. The time now is 01:22 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.