Pontiac GTA Enhancement information and discussions with Technical DIY and performance tuning information for the hardcore Pontiac GTA Owners and Enthusiasts.
Forum | Register Now | Members | Search | How Do I... | Calendar

Go Back   The GTA Source Page Message Forums > GTA SPECIFIC > GTA TECH

GTA TECH Want to discuss technical topics about your GTA.... engine tuning, mechanical upgrades, problem areas, etc.? Then post it HERE!

Reply
 
Thread Tools Display Modes
Old 08-04-2005   #1
dziurkens89GTA
Registered User
 
Join Date: Oct 2004
Posts: 35


bad engine work

Hi

I have a new problem with my rebuild GTA 89

When I start a cold engine revolutions falls a little (+/- 20-30rpm) . This happens at idle and when I press the pedal and pushing it to example 3000rpm. When the engine gets warm temp rpm falls awfully! at idle +/- 200-300 rpm !!

engine not overheating , no vacuum leaks (checked with carb cleaner)
perfomance is very very good.

behind is a specs

1989 ZRC Corvette engine
stock bottom end
stock cam and valve train
113 alu heads (heavily ported)
TPI (ported plenum, siamese runners (base is stock)
stock ignition
AFPR (I can't checking the fuel pressure now but I do that tomorrow)

no trouble codes

spark plugs are new, I pulled out today and looks fine.


:/ help
dziurkens89GTA is offline   Reply With Quote
Old 08-04-2005   #2
nblanchard
GTA Member
 
nblanchard's Avatar
 
Join Date: Oct 2001
Location: North York, ON Canada (Toronto)
Posts: 870


Re: bad engine work

test the throttle position sensor?
__________________
Best Track Time is 14.396 @ 95.71MPH

225.5hp @ 4250rpm (at the wheels)
325.8ft-lbs @ 3250rpm (at the wheels)
nblanchard is offline   Reply With Quote
Old 08-05-2005   #3
dziurkens89GTA
Registered User
 
Join Date: Oct 2004
Posts: 35


Re: bad engine work

Quote:
Originally Posted by nblanchard
test the throttle position sensor?
Tested 2 sensors. no effect... :/
dziurkens89GTA is offline   Reply With Quote
Old 08-05-2005   #4
nblanchard
GTA Member
 
nblanchard's Avatar
 
Join Date: Oct 2001
Location: North York, ON Canada (Toronto)
Posts: 870


Re: bad engine work

you tested the voltage at your throttle positions sensor? Did it sweep smoothly? what was the voltage with the throttle shut?
__________________
Best Track Time is 14.396 @ 95.71MPH

225.5hp @ 4250rpm (at the wheels)
325.8ft-lbs @ 3250rpm (at the wheels)
nblanchard is offline   Reply With Quote
Old 08-06-2005   #5
dziurkens89GTA
Registered User
 
Join Date: Oct 2004
Posts: 35


Re: bad engine work

Quote:
Originally Posted by nblanchard
you tested the voltage at your throttle positions sensor? Did it sweep smoothly? what was the voltage with the throttle shut?
0.54V when throttle close, 4.39V @ WOT, voltage increases smoothly

hmm I re check the injectors resistance 6 of them have above 17V (17.1-17.3V) but on the last two ohm-meter shows 20.1V... I know if resistance is too low it not good, but what about if it is too high?

Today i'll put a manometer and checks the fuel pressure ...

thanks for help
dziurkens89GTA is offline   Reply With Quote
Old 08-06-2005   #6
nblanchard
GTA Member
 
nblanchard's Avatar
 
Join Date: Oct 2001
Location: North York, ON Canada (Toronto)
Posts: 870


Re: bad engine work

those injectors sound fishy
__________________
Best Track Time is 14.396 @ 95.71MPH

225.5hp @ 4250rpm (at the wheels)
325.8ft-lbs @ 3250rpm (at the wheels)
nblanchard is offline   Reply With Quote
Old 08-13-2005   #7
dziurkens89GTA
Registered User
 
Join Date: Oct 2004
Posts: 35


Re: bad engine work

Hi Nathan

I connected the fuel pressure gauge to my car. that's the results:

-engine idling @750rpm, pressure fluctuating very fast from 58 to 65PSI!!!

on any other rpm effect is the same. I disconnect the vacuum line from FPR and plugged it - no changes - still very fast fluctuating....

jeezz this car makes me really bad :/
dziurkens89GTA is offline   Reply With Quote
Old 08-15-2005   #8
nblanchard
GTA Member
 
nblanchard's Avatar
 
Join Date: Oct 2001
Location: North York, ON Canada (Toronto)
Posts: 870


Re: bad engine work

that fuel pressure seems pretty damn high to me.. and removing that vacuum line should have changed your pressure... I think you have a bad FPR there... anyone else think so?
__________________
Best Track Time is 14.396 @ 95.71MPH

225.5hp @ 4250rpm (at the wheels)
325.8ft-lbs @ 3250rpm (at the wheels)
nblanchard is offline   Reply With Quote
Old 08-15-2005   #9
dziurkens89GTA
Registered User
 
Join Date: Oct 2004
Posts: 35


Re: bad engine work

Quote:
Originally Posted by nblanchard
that fuel pressure seems pretty damn high to me.. and removing that vacuum line should have changed your pressure... I think you have a bad FPR there... anyone else think so?
I think too that FRP sucks I'll swap to friend one at wednesday
but I don't have a plenum& runner gaskets use a old ones maybe not creates a vacuum leak :>
dziurkens89GTA is offline   Reply With Quote
Old 08-15-2005   #10
nblanchard
GTA Member
 
nblanchard's Avatar
 
Join Date: Oct 2001
Location: North York, ON Canada (Toronto)
Posts: 870


Re: bad engine work

well... i guess you could try the old ones... its not like those gaskets are hard to change anyway
__________________
Best Track Time is 14.396 @ 95.71MPH

225.5hp @ 4250rpm (at the wheels)
325.8ft-lbs @ 3250rpm (at the wheels)
nblanchard is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
recomended engine replacement.. CavanGTA GTA TECH 7 06-08-2005 06:20 PM
Engine Probs tommydodso GTA TECH 3 03-16-2004 07:31 PM
1 BAD 1988 GTA For Sale in Tampa, FL 1BAD88GTA GTA CARS FOR SALE 0 08-30-2003 04:31 PM
removeing engine from tranny 89GTA GTA TECH 31 03-07-2002 11:35 PM
engine problem 89GTA GTA TECH 7 01-19-2002 02:31 AM


All times are GMT -5. The time now is 12:57 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.