Pontiac GTA Enhancement information and discussions with Technical DIY and performance tuning information for the hardcore Pontiac GTA Owners and Enthusiasts.
Forum | Register Now | Members | Search | How Do I... | Calendar

Go Back   The GTA Source Page Message Forums > GTA SPECIFIC > GTA TECH

GTA TECH Want to discuss technical topics about your GTA.... engine tuning, mechanical upgrades, problem areas, etc.? Then post it HERE!

Reply
 
Thread Tools Display Modes
Old 07-23-2000   #1
REMOVED USER
Guest
 
Posts: n/a


code 12: No Refference Pulses to ECM?

My car has been running rough and I pulled the code and it's 12. Code 12 means NO REFFERENCE PULSES TO ECM. What does this mean? Is there anything I can check like connections somewhere or does this mean my ECM needs to be replaced. Where is the ECM located? I have an 88 GTA with the 5.7.
  Reply With Quote
Old 07-24-2000   #2
REMOVED USER
Guest
 
Posts: n/a


Code 12: No reference pulses to ecm.

I have an 87 GTA, 5.7 litre. I had a similar problem a few months ago. The car ran terribly. It was discovered that the number 2 injector was bad. The easiest way to troubleshoot this is to disconnect the injector wires one at a time while the engine is at idle. When or if you disconnect a wire and the engine idle does not change, you have found a bad injector. A misfiring injector will give a code 12 reading because the ECM is doing what it supposed to do by sending a certain amount of fuel to this injector, only the injector is not properly dispensing the fuel into the prescribed cylinder. Hope this helps.
  Reply With Quote
Old 07-25-2000   #3
REMOVED USER
Guest
 
Posts: n/a


Re: Code 12: No reference pulses to ecm.

Were you getting a check engine light? or was your car just running ruff? When i scan my car it always gives a code 12 indicating that there is no other codes that are being sent to the computer. What was your car doing when it was running ruff?
  Reply With Quote
Old 07-25-2000   #4
REMOVED USER
Guest
 
Posts: n/a


Re: code 12: No Refference Pulses to ECM?

if you have any other questions you can email me at sean@pnpa.net. I have had so many problems with my 88 gta that i could probrably give ya a couple of hints.
  Reply With Quote
Old 07-25-2000   #5
REMOVED USER
Guest
 
Posts: n/a


code 12

The code 12 just lets you know that the ECM is in diagnostic mode this will flash three times then the ECM will begin to give you any trouble codes it may be storing these will also flash three times each, the ECM will flash the code 12 when it has given you all the trouble codes. If you have a check engine light the first test I would do is the tapp test,lightly tapp on the ECM while the engine is running,if this couses a change in the engine the ECM is bad.This was recomended by the dealer mech. I spent a few hundred chasing the ECM code I had before I tried the tapp test, it would have been cheeper just to do this first and just replace the ECM then go through all I went through to find this out. My GTA runs great know.
  Reply With Quote
Old 07-25-2000   #6
REMOVED USER
Guest
 
Posts: n/a


Re: code 12

It was just running rough. I took it to the local dealership and I suggested that it might be my fuel pump as I had encoutered this failure 10 years ago in my 86 Camaro. After the $70 Diagnostic fee they told me it was the Throttle body gasket. They replaced the $4 part for $130 and called me 2 hours later to tell me that there was something else wrong. I now needed a new Distributor shaft, cap, rotor and plug wires which they could replace for $790 plus tax. Being mechanically inclined, I opted to do it myself for $320 (Accel Dist and wires) with zero results. I took it back to them and then they told me the Mass Air Flow sensor was bad (even though the only code I have gotten from the car is 12) and they could replace THAT for $498. I told them to do it but they did not have the part in stock so I found the part and did it myself. AGAIN, zero change. I took it back to them again and guess what, as it turns out it is in fact my fuel pump and they will change that for $550. I think not. I will do this myself as well. They are denying any wrong diagnosis and they stand strong that my car, as old as it is (with only 82000 miles by the way) just had all of these coincidentally go bad all at the same time. If ever in the Tampa, Florida area, DO NOT take your car to COURTESY PONTIAC on Hillsboro Avenue. They do NOT know what they are doing in my opinion.

Thanks for the suggestions fellow listers.
Scott
  Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:26 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.