Thread: engine pings
View Single Post
Old 11-05-2005   #58
george88gta
Registered User
 
george88gta's Avatar
 
Join Date: Oct 2002
Location: holmes,ny
Posts: 904


Re: engine pings

Quote:
Originally Posted by nblanchard
oh yeah... for sure... do that man... it takes, what, 10 minutes max to swap it out?
Well, today was a really nice day around here, 70 degrees,dry and sunny. Swapped in the original chip. Car started, idled poorly. It would stall when I put it in gear until it warmed up, was idling around 400-500 rpm in gear, barely running. Took it for a ride so the chip/pcm could learn the engine. No real improvement in idling, pinging was terrible. It was so bad that I pulled in to a parking lot and put the Hypertech custom chip back in. I know the knock sensor circuit works, tap the exhaust manifold with a hammer and you can see the timing retard, but it doesnt seem to do anything to correct the pinging. I did some research and the newer GM crate 350's specify maximum total timing at 32 degrees advance. This chip is giving me as much as 38 degrees advance. Sent a note to GM and they basically blew me off, they said to contact a GM Performance Parts dealer for info. I sent an email to Pace Performance ( where I purchased the engine) waiting to see if they can offer any advice. Really starting to think the chip is too aggressive for this engine and the 93 octane fuel that has 10% ethanol, isnt helping either. Almost glad that winter is coming and the car will be put in storage, leaving this headache for the spring.
george88gta is offline   Reply With Quote