The GTA Source Page Message Forums

The GTA Source Page Message Forums (http://www.gtasourcepage.com/forum/index.php)
-   GTA NON-TECH (http://www.gtasourcepage.com/forum/forumdisplay.php?f=326)
-   -   What have you done to your GTA this winter. (http://www.gtasourcepage.com/forum/showthread.php?t=51476)

88 Black GTA 03-06-2009 04:45 PM

What have you done to your GTA this winter.
 
Just wondering what if anything everyone has done to their GTA's over the winter.

I did the following:

Replaced the nylon guides in the hatch pull down motor.

Replaced the blower motor relay.

Replaced the center link and idler arm in the front end. Still need to do the tie rods.

Just ordered new injectors. I plan on adding a adjustable FPR and port matching the runners and plenum while I am in there.

Still want to upgrade the front brakes with 4th gen LS1 pieces before summer.

Anyone else done anything to their cars?

FearThisGTA 03-06-2009 06:12 PM

Re: What have you done to your GTA this winter.
 
Put in a new Alpine hd unit with ipod hook ups. :rockon: I gotta rebuild the frt end soon. I have only put about 168k miles on it since I last rebuilt it. :eek:

Klortho 03-06-2009 08:31 PM

Re: What have you done to your GTA this winter.
 
I let mine collect more dust as I drive the '98 all the time now......

I really need to charge the battery on it and fire it up....it's only been a year now since it's been started.

GTA50 03-06-2009 10:57 PM

Re: What have you done to your GTA this winter.
 
I haven't done much either. I've been playing with my 1989 2.8L stroker Firebird and my 1984 Trans Am. I did go for a cruise with some members if CamaroSource.ca, so here are some pictures:

http://s274.photobucket.com/albums/jj256/GTA50/

strc09 03-07-2009 09:14 AM

Re: What have you done to your GTA this winter.
 
Lots. :sly:

Wes 03-07-2009 11:02 AM

Re: What have you done to your GTA this winter.
 
Parked it under a car cover and (BIG NEWS!!!)bought new gray valve stem caps. Going to get the U1A cd players serviced and still looking for replacement woofers for the factory enclosure.

strc09 03-07-2009 04:29 PM

Re: What have you done to your GTA this winter.
 
Quote:

Originally Posted by Wes
still looking for replacement woofers for the factory enclosure.

Speaking of which...does anyone have pictures of their UQ1 sail speakers and how they install in the car? I've got a set that I want to get in my car and I want to see how they go in before I start taking panels off and such.

Arrow 03-07-2009 05:43 PM

Re: What have you done to your GTA this winter.
 
Ball joints, Idler arm, plugs, chased down and repaired a broken MAF wire, wiper blades, and LS1 front brakes

To do list: centerlink, struts, strut mounts, tie rods, and finish rebuilding my T-56, and then swap it in.

I just realized, I need to do a bunch of crap lol

FrankieRider2 03-07-2009 11:53 PM

Re: What have you done to your GTA this winter.
 
Well, I've started mine weekly.... and made sure the Battery Tenders are hooked up properly.

Fade2BlackGTA 03-07-2009 11:59 PM

Re: What have you done to your GTA this winter.
 
Nothing but look at it. Getting ready start work again soon.

merc3065 03-08-2009 12:50 AM

Re: What have you done to your GTA this winter.
 
strc09 : UQ1 speakers are bolt in. Super easy to get them into the sails.

You have to unbolt your coat hooks, pull the sail panel out. Unhook the existing 6x9 speakers, take the 7mm screws out of the metal frame for the 6x9 foam enclosure. Then, drop the UQ1 boxes in, use the 4x 7mm screws, wire up the speakers as you see fit, put the sail panel and coat hook back in place. There is really nothing to it. You might want to line the outside of the sheet metal opening with some dynamat or similar stuff so you avoid any rattle/vibration.
Another thing that can happen if you have a set of 5" speakers that really pound, is the door heat pressure valves will flutter and make an annoying flappy noise when the bass hits.

What i've done with my car? Killed the battery in it a second time (left it in the cold so it probably froze) got it appraised, ordered the ram air 1 hood, 2 axle shafts and the 2 front fenders.

Will be putting those on during the next warm day. I don't expect to see one for another few weeks yet...

southgta 03-08-2009 12:21 PM

Re: What have you done to your GTA this winter.
 
New motor mounts, no fun, a tyranny cooler, and LS1 brakes!

strc09 03-08-2009 05:01 PM

Re: What have you done to your GTA this winter.
 
Merc, sounds easy enough. I just wanted to make sure that it was going to be a simple swap. I'd like to get those in soon. I'm also looking for a small amp (in size) Pioneer used to make one that I had when I had my 83, but I sold all the stereo stuff after I totaled the car. I kind of wish I had held onto it because I had the amp and an EQ that I could have used in my GTA, but I didn't know I would eventually own another GenIII after that.

mavs88gta 03-09-2009 10:57 AM

Re: What have you done to your GTA this winter.
 
Still fighting this damn coolant leak!!!!!

87bucketgta 03-09-2009 11:35 AM

Re: What have you done to your GTA this winter.
 
The bucket has a rear main seal leak needs to fix just not looking forward to taking all that crap off the car to get to it, really dont have the free cash to pay someone to do it right now. Besides that nothing new with the car runs good.

DUBGTA88 03-09-2009 06:45 PM

Re: What have you done to your GTA this winter.
 
Well I'm finally going to have my 700r4 re-build in the next month or so, since I finally have the money. I'm planning on installing an slp 2400 stall converter that I've had for a long time, with a lighter flex plate (any recommendations?). I am also planning on having a shift kit and corvette servo installed with stronger internals. I already installed a cooler for the tranny and plan on adding a trans cooler gauge for safety purposes. Do you guys have any recommendations that I should do while the tranny is out?

FearThisGTA 03-09-2009 09:30 PM

Re: What have you done to your GTA this winter.
 
On the flex plate there aint no sense in gettin another one unless that one is cracked. That is if your car is still Tpi, if not then get one suitable to the rpm's the motor is turnin. As for wht to do while its out, first replace the rr main seal, then replace the shifter cable and get a new trans mnt, imho, I like the poly ones the best. And then if it aint ready then replace the mtr mounts as well. hth

88blckdrgnGTA 03-10-2009 02:16 AM

Re: What have you done to your GTA this winter.
 
Replaced entire rear deck lid pull down unit. Only piece that worked was the old motor but put in a new style anyway. Got the horn working again, tinkered here and there fixing problems as they arose. Looking forward to warm weather to cruise in again.

DUBGTA88 03-10-2009 02:41 AM

Re: What have you done to your GTA this winter.
 
Quote:

Originally Posted by FearThisGTA
On the flex plate there aint no sense in gettin another one unless that one is cracked. That is if your car is still Tpi, if not then get one suitable to the rpm's the motor is turnin. As for wht to do while its out, first replace the rr main seal, then replace the shifter cable and get a new trans mnt, imho, I like the poly ones the best. And then if it aint ready then replace the mtr mounts as well. hth

I'm going to be replacing the rr main seal and the shifter cable now that you mention it. Should I replace the cable with o.e.m. or should I go aftermarket? Do you think poly motor mnt would be the better type to use? I replace the tranny mnt with a poly one when I bought the car and love it but not sure how good they work on motors. Some people say no and some say yes. What do you guys think? I was thinking that a lighter flex plate would let my motor rev up faster and help on 0-60 and 1/4 mile times. Do you think it would be a waist of money?

FearThisGTA 03-10-2009 06:00 AM

Re: What have you done to your GTA this winter.
 
On the cable, either will be fine. If it was the tv cable OH and btw, change that out too. I KNEW there was somethin I was forgettin. :o ON the tv cable get a new one from GM. THen let the trans shop do the adjustin when you get it back in.
As for the poly mnts on the eng, imo, I would. As for the flex plate, again unless that motor is gonna be seein high rpms as in over 7k then yes get one, but for our motors its just over kill and imo, $$$$ wasted. hth


All times are GMT -5. The time now is 09:40 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.