The GTA Source Page Message Forums

The GTA Source Page Message Forums (http://www.gtasourcepage.com/forum/index.php)
-   GTA NON-TECH (http://www.gtasourcepage.com/forum/forumdisplay.php?f=326)
-   -   lost of power help!!!! (http://www.gtasourcepage.com/forum/showthread.php?t=49329)

littleredgta 04-18-2006 07:07 PM

lost of power help!!!!
 
need some advise,i have had a major lost of power,what or where should i start,i was putting in the tank midgrade,but 4 the last three tank's cause of the $2.59 a gallon 4 just the cheap gas i started to use it stopped,when i started losing power added injector cleaner,thought it would help,but made it worse!!,now the only way i can light em'up is by putting it in first,and even than it's still not the same!!!!!please help gta loseing life help bring her back,any input welcome and thank's :( !!!!!!!

FearThisGTA 04-18-2006 07:41 PM

Re: lost of power help!!!!
 
Have you replaced the fuel filter?

ZZ4GTAMan 04-18-2006 09:11 PM

Re: lost of power help!!!!
 
Is it possible you got some bad gas?

Mike

Fred91GTA 04-18-2006 10:21 PM

Re: lost of power help!!!!
 
Replace your fuel filter. Add some 93 octane in there again. Don't ever put anything less in there again. My car had the same problem. Turns out that my fuel injectors were pretty bad. I replaced mine with new ones, along with a full tune up and everything was better than the day I got it.

gtayumiko 04-19-2006 05:19 PM

Re: lost of power help!!!!
 
Quote:

Originally Posted by ZZ4GTAMan
Is it possible you got some bad gas?

Mike

Oh yes, I put some bad gasoline in my car long time ago on a trip and it really make it run so bad without good power. Would gasoline with moisture in it do this too? I think so, I only imagine what moisture would do and it seem it would make you really loose a lot of power. I know another one that would make you loose power bad also but I can talk about that one some other time, has to do with putting on those caps between spark plug and head, these were use if you are fouling out spark plugs because of small oil leaking. Yumiko

littleredgta 04-25-2006 05:27 PM

Re: lost of power help!!!!
 
replaced filter,put in some new splitfireplugs,new wires,also had the injectors cleaned,and man she is back,and i mean back,you never know what your missing till it's gone!!!!!!!!


All times are GMT -5. The time now is 03:16 PM.

Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.